transcode refusal

Need help with a script? This is the place to discuss how to get your code running!

transcode refusal

Postby haroldomauro » Wed Jan 11, 2017 3:56 pm

I've had this project for several years, into which I had installed the Transcode external. It worked fine in a script until today. When I ran the script today it gave the error -1 "never heard of that handler". I clicked "script". The cursor was at the transcode line. I checked and confirmed that the external was still there, installed. So I deleted it and tried to install it again, but the project appeared greyed out when prompted to choose a project to install. When I switched to "choose a file..." then the project became available. I then installed it but I keep getting the "never heard..." error.
haroldomauro
 
Posts: 60
Joined: Sun May 02, 2010 3:08 am

Re: transcode refusal

Postby Scott » Thu Jan 12, 2017 6:29 am

What version of SuperCard?
User avatar
Scott
Site Admin
 
Posts: 1214
Joined: Sat Jul 05, 2008 1:37 pm
Location: Northern Sierra Nevada

Re: transcode refusal

Postby haroldomauro » Sat Jan 14, 2017 2:02 pm

v.4.7. Actually, I was using b4.85 when it happened the first time. Then I opened the project in 4.7.3 hoping it was a bug in the beta but the thing persisted. Thanks.
haroldomauro
 
Posts: 60
Joined: Sun May 02, 2010 3:08 am

Re: transcode refusal

Postby Scott » Mon Jan 16, 2017 9:24 am

I am afraid I am not seeing this in either 4.7.3 or 4.8b25. In fact, the Transcode external is in 4.8b25's SharedFile so you shouldn't even need to install in projects used with it.

BTW, installing it to a file will install it to the resource fork of the file. Installing to a project will put it in the data fork of the project (which is where it needs to be).
User avatar
Scott
Site Admin
 
Posts: 1214
Joined: Sat Jul 05, 2008 1:37 pm
Location: Northern Sierra Nevada


Return to Scripting in SuperTalk

Who is online

Users browsing this forum: No registered users and 1 guest