Installing MPI

Here's where to discuss using Stéphane Leys' very well done alternative runtime editor. If you're a control freak at runtime you have to check this out!

Installing MPI

Postby S. Leys » Tue Nov 17, 2009 2:27 am

When downloading MPI, you'll get a folder containing the MPI files.
The folder also contains a project named "install MPI" aka, the installer. You must open this project and follow the instructions, it will copy all the MPI files into the SC Pouch. You must NOT try to open the MPI project which is in the downloaded folder, this would send an alert saying that MPI must be in the SC Pouch and the project would close itself. The reason of this is explained in the FAQ of the MPI Help project (which you open with the Help app). You'll keep the downloaded folder as a backup.
After the installation is completed, the installer will ask you if you want to open MPI (or open it automatically if an older version was open when running the installer).
Then, I would recommend to open the preferences (menu "file" of the menu bar in the palette) and set MPI as the default editor, with or without the RTE). This ensures that SC will open the right copy of MPI from the SC Pouch when launched.
There is no drawback in doing this, it is very easy to open or close the RTE from MPI's "utilities" menu. it is easy to close MPI, just click the closebox of the main palette (the one with the MPI logo and the menu bar). This will close all the modules. When opening MPI again, it will open the modules as they were when you closed it.
For opening MPI again, you can either drag it to the file section of the dock (the most handy way, IMHO) or add this in the shared script :
Code: Select all
on mpi
    open proj  (projectpath(proj "sharedFile") & "modulopi")
end mpi

Then, you'll jut have to type "mpi" in the message box.
The MPI preferences allow setting MPI as the default editor alone or with the RTE or revert to the RTE alone. If you're using a trial version and the evaluation period expires, MPI will first ask you for the code and, if you don't enter it, it will close itself. BUT before doing this, it will reset the default editor to the RTE and open it. So, there is no reason to be scared.

Note to registered users :
Usually, when the installer finds an open registered version of MPI, it will copy the registration info from the old version and automatically register the new version (you''l get an alert saying that this has been done).
This is not the case with 4.3.0 because I've changed the registration code.
All registered users should have received their new code. If you didn't get it, first look at your spam folder and if you find it here, update your filters. If you don't find it, email me privately.
So, after installing 4.3.0, you must enter this new registration manually as explained in the mail. I recommend doing it now because, since I've reset the 30 days evaluation period, MPI won't ask for the code before this period expires and, in the meantime, you'll have forgotten where you saved the code ;-).

User avatar
S. Leys
Posts: 628
Joined: Sun Jul 06, 2008 11:03 am

Return to Using MPI

Who is online

Users browsing this forum: No registered users and 1 guest