PopUpMenu

Having trouble using an XCmd or XFcn? Post your questions here.

PopUpMenu

Postby GLBledsoe » Thu Feb 11, 2010 8:33 am

I has a project which uses PopUpMenu Xfnc. It works fine in SuperCard, but I get an error when using it with SuperCard player: "Never heard of the function name." That would mean that PopUpMenu Xfcn isn't installed, but I did install it into the project. It's there when I check the Resource Manager. I'm puzzled.
GLBledsoe
 
Posts: 6
Joined: Tue Sep 15, 2009 9:41 am

Re: PopUpMenu

Postby Scott » Thu Feb 11, 2010 9:02 am

I am guessing the external in your project is old and not compatible with the version of the Player/Mac you are using. Try replacing it with the current version that is in Xtend.
User avatar
Scott
Site Admin
 
Posts: 1232
Joined: Sat Jul 05, 2008 1:37 pm
Location: Northern Sierra Nevada

Re: PopUpMenu

Postby GLBledsoe » Thu Feb 11, 2010 9:47 am

I've got SuperCard 4.6.3. Do I just download the trial version to update?

Thanks.
GLBledsoe
 
Posts: 6
Joined: Tue Sep 15, 2009 9:41 am

Re: PopUpMenu

Postby Scott » Thu Feb 11, 2010 9:55 am

No… you're current, but the popupMenu XFcn in your project may not be. Especially if it is labeled as 'Xfcn' and not 'XFcn'.
User avatar
Scott
Site Admin
 
Posts: 1232
Joined: Sat Jul 05, 2008 1:37 pm
Location: Northern Sierra Nevada

Re: PopUpMenu

Postby GLBledsoe » Thu Feb 11, 2010 10:10 am

How then do I update?
GLBledsoe
 
Posts: 6
Joined: Tue Sep 15, 2009 9:41 am

Re: PopUpMenu

Postby Scott » Fri Feb 12, 2010 9:50 am

Just delete the old external and install the current one that is in Xtend. You can use SuperEdit to do this, the Resource Manager in SuperCard, or the Help System.
User avatar
Scott
Site Admin
 
Posts: 1232
Joined: Sat Jul 05, 2008 1:37 pm
Location: Northern Sierra Nevada

Re: PopUpMenu

Postby GLBledsoe » Fri Feb 12, 2010 7:08 pm

For whatever reason I am unable to install Popupmenu from Xtend in Help. But I was able to copy it over from a different project using Resource manager. For some reason SuperCard Xtend is not letting me install any XCmd into any project. Could it be corrupted? It's not impossible that I'm doing something wrong, but I'm not a novice user. I started using HyperCard in 1990 and learned how to install xcmd's 20 years ago.
GLBledsoe
 
Posts: 6
Joined: Tue Sep 15, 2009 9:41 am

Re: PopUpMenu

Postby Scott » Sat Feb 13, 2010 7:40 am

GBledsoe wrote:For some reason SuperCard Xtend is not letting me install any XCmd into any project.

Try closing the project before installing the external.
User avatar
Scott
Site Admin
 
Posts: 1232
Joined: Sat Jul 05, 2008 1:37 pm
Location: Northern Sierra Nevada


Return to Using Externals

Who is online

Users browsing this forum: No registered users and 1 guest